ESTRUTURA CONDICIONAL SIMPLES E COMPOSTA

Para todos os exercícios abaixo, faça o programa usando a condicional simples (SE...FIMSE)
Depois, refaça o programa usando condicional composta (SE...ENTAO...FIMSE)

1) Faça um programa que leia a altura de uma pessoa.
Exiba "BAIXO" se a altura lida é menor que 1,60
Exiba "ALTO" se a altura é maior ou igual a 1,60

2) Faça um programa que leia o estoque e o preço de um produto e um tipo de pagamento (V à vista e P à prazo)
Exiba "Sem Estoque" se o estoque é menor ou igual a zero
Se o tipo for à vista calcule um desconto de 10% e exiba o preço líquido
Se o tipo for à prazo calcule o valor dividido por 2 e exiba o valor da prestação

3) Faça um programa que leia número de faltas e nota final de um aluno
Exiba "REPROVADO POR FREQUÊNCIA" se o aluno tem mais de 20 faltas
Exiba "APROVADO" se sua nota é maior ou igual a 6
Exiba "EXAME" se a sua nota é de 4 a 5,9
Exiba "REPROVADO POR NOTA" se a nota é menor que 4

 


4) Faça um programa que leia o preço de um produto, o tipo de pagamento e a sigla do estado (UF) do cliente:

4.1. Calcule um desconto simples no preço do produto de acordo com a tabela abaixo:
preço menor que 100,00: não tem desconto
preço de 100,00 a 500,00: 10 reais de desconto
preço de 500,01 até 1000,00: 50 reais de desconto
preço acima de 1000,00: 100 reais de desconto

4.2. Calcule outro desconto para o preço do produto. Se o tipo de pagamento for à vista (V), dê 5% de desconto. Se for à prazo (P), dê 3% de desconto.

4.3. Calcule uma taxa de frete aumentando o preço do produto de acordo com o estado:
se for sudeste (MG, SP, RJ ou ES) aumente 8,00
se for sul (PR, SC, RS) aumente 12,00
qualquer outro estado: aumente 20,00.

4.4. Calcule o preço final do produto diminuindo o valor dos dois descontos e aumentando a taxa de frete. Exiba todos os valores calculados com a descrição de cada um.
Desconto Simples = 000,00
Desconto V ou P = 000,00
Taxa de Frete = 000,00
Preço Final = 000,00

RESPOSTA:

algoritmo "semnome"

var PRECO, DESCONTO1, DESCONTO2, FRETE, PRECOFINAL: REAL
      TIPOPAG: CARACTER
      SIGLA: CARACTER
inicio
    ESCREVA("PREÇO DO PRODUTO:")
    LEIA (PRECO)
    ESCREVA("TIPO DO PAGAMENTO V/P:")
    LEIA (TIPOPAG)
    ESCREVA("SIGLA DO ESTADO:")
    LEIA (SIGLA)

    SE PRECO < 100 ENTAO
         DESCONTO1 <- 0
    SENAO
        SE (PRECO >= 100) E (PRECO <= 500) ENTAO
             DESCONTO1 <- 10
        SENAO
             SE (PRECO >= 500.01) E (PRECO <= 1000) ENTAO
                   DESCONTO1 <- 50
             SENAO
                   DESCONTO1 <- 100
             FIMSE
        FIMSE
     FIMSE

     SE TIPOPAG = "V" ENTAO
           DESCONTO2 <- PRECO * 0.05
     SENAO
           DESCONTO2 <- PRECO * 0.03
     FIMSE

ESCOLHA (SIGLA)
    CASO "MG", "RJ", "SP", "ES"
         FRETE <- 8
    CASO "PR", "SC", "RS"
         FRETE <- 12
    OUTROCASO
         FRETE <- 20
FIMESCOLHA

PRECOFINAL <- PRECO - DESCONTO1 - DESCONTO2 + FRETE
ESCREVAL("DESCONTO 1:", DESCONTO1)
ESCREVAL("DESCONTO 2:", DESCONTO2)
ESCREVAL("VALOR FRETE:", FRETE)
ESCREVAL("PREÇO FINAL:", PRECOFINAL)

fimalgoritmo